Fandom

DarkScape Wikia

Batwing boots

19,506pages on
this wiki
Add New Page
Comments0 Share
Batwing boots
Batwing boots
Release date 20 November 2012 (Update unknown) edit
Members No
Quest item No
Tradeable Yes
Equipable Yes
Edible No}}{{#vardefine:heal1|}}No
Stackable No
High alch 120 coins
Low alch 80 coins
Destroy Drop
Store price Not sold
Exchange price 2,028 coins (info)
Buy limit 100
Examine Supple, stylish footwear for mages.
Weight 0 kg
Loading...
[view] [talk]
Batwing boots detail

The Batwing boots are magic armour worn in the boot slot. They require 30 Defence to wear. They are part of the Batwing robes armour set, and were released with the Evolution of Combat.

Players can make them by using a needle and thread on one piece of batwing, requiring 52 Crafting and giving 50 Crafting experience.

Combat Stats160x350px
Skill requirements
30 Defence-icon
ClassSlot
Magic MagicBoots slot
WeaponsMainOff
Damage--
Accuracy--
Style-
Attributes
Defence-iconArmour42
Constitution-iconLife points0
Prayer-iconPrayer0
Strength bonuses
Strength-icon0Ranged-icon0Magic-icon0
[view][talk]

TriviaEdit

  • During the Evolution of Combat beta, this item's examine text was "Kapow!" This is a reference to the original Batman television series, in which fight scenes were comically covered with similar text.
  • When DarkScape was originally released, this, as well as all other Batwing equipment had level 50 requirements and stats. However, an update on September 24, 2015 switched the stats and requirements of batwing robes for mystic robes.
  • These boots are the only piece of the batwing set that does not have a distinct purple colouration.

This page was moved from runescape:en:Batwing boots. It's edit history can be viewed at Batwing boots/edithistory

Ad blocker interference detected!


Wikia is a free-to-use site that makes money from advertising. We have a modified experience for viewers using ad blockers

Wikia is not accessible if you’ve made further modifications. Remove the custom ad blocker rule(s) and the page will load as expected.